How to save yer fooked AZbox HD...


Donating Member
Notepad++ does not work because changes the file structure on save & exit. File is too big to Open it in DCC.
HDD HEX EDITOR NANO did ok upon save, file was clean and readable with itself and Notepad++

However after first Jtag trial zboot failed (previously it was working and I had to stop booting using Ctrl-c to allow jtag).
I was a bit greedy and I changed the date of manufacturing along with 1 character in MAC address.

I start from scratch only changing the MAC and now I am half way.
I would like to update the same message with the final conclusions (if any) instead of adding more....

Jtag took every time about 40 hours every time and I am surprised that in the instructions FC.Candido is talking about 5-6 hours flash time( I am not very good at Spanish)
But many thanks for posting the files and instructions ...Could not do it without.
Last edited:


Donating Member
Yes I did,
after 3rd attempt I give up, it did not work, for now I will use wifi and will try to see if a change in init file will modify the MAC.
There might be an algorithm that I miss in regards how to change it the right way

The other Azbox I do not want to touch it for now (in other words I do not want to screw-up that one too)

I am running out of ideas and jtag is very long process - about 40 hours or 1 byte almost every 3 sec.

Sorry if I will be able to fix it I will let you know.
I can run multiple routers but if you run a single you can see all your E2 enabled devices at once, mount same
drive/server drive with all your E2 devices....etc. That was the whole point of running different MAC
addresses on a single DHCP router + numerous switches.
Last edited:


Donating Member
Seen been done
100 % success, I was able to change the MAC #.
If the owner / maker of the original jtag/reflash package
would like to add this info is welcome.

I was able to do it using YAMON.

First time when my azbox was 100% healthy and I stopped the booting process at start using ctrl-c
Yamon did not allow me to change it. You can still try maybe I did something wrong.

Second time it was after jtag the box (parallel cable, az3.bin file..).
I did it right after the first setxenv command and before using pumpkin to load vmlinux.bin .

Yamon allowed me to change it...even the documentation says different.
Here are the steps
YAMON> setxenv
(you can read the existing eth_mac #)
79 records, 1704 bytes

YAMON> setxenv a.eth_mac 00:xx:xx:xx:xx:BB
Original value "00:xx:xx:xx:xx:BA", New value: "00:xx:xx:xx:xx:BB"
Updating XENV block at 0x48000000
XENV verification OK.
Last edited:


azbox premium boot problems

i'm trying to save an azbox premium with boot problems.
it stucks on booting with OFW as also with E2 FW.
if power of the box and live it for 30mins then it start normally, but at the next reboot it stucks again.
when connected with rs232 (yamon cable) i get this message from telnet: POWER SUPPLY:FAIL
for any help please


Well Known Member

People keep coming with the broken box question, so this could prevent a lot of similar threads, if it's stuck, guys...


Azbox blocked in booting

I've tryed to recover my Azbox HD Elite using the RS232-TTL adapter and after:
1) connecting cables
2) starting Putty
3) turning on the power supply
I've seen on the puttty windows:

xosPe0 serial#365549cdc5d3e881979777b18eae5018 subid 0x50
xenv cs2 failed
xenv cs3 failed¡øpower supply: ok
dram0 ok (8)
zboot (1) failed

Obviuously it was not possible to send the CTRL-C key to stop BOOTING because I'm not arrived at the point where it is equired.

What could I do to recover it?:mecry::mecry:


Thanx to terzic (my translation), his home-made brew...

One needs
TFTPD32 file/package
backup_kernel (you'll find it in TFTPD32 folder)
Serial Interface to connect to AZBox HD

You also need your PC's IP address (via command prompt):
Start -> Run -> write: cmd -> hit enter on your keyboard -> ipconfig -> enter -> your PC's IP address is there

If your PC IP address =
We choose AZbox HD IP address, let's say

1. Start TFTPD32
2. Start Putty, choose serial, put the COM port where your serial interface is, Speed = 115200
3. Connect serial interface with AZBox and switch AZBox ON
4. Press CTRL+C to stop the booting
5. Write:

setxenv y.ipaddr
setxenv y.gateway
setxenv y.subnetmask
net init
load -b tftp:// 0xb0100000
pflash write -f 0x80000 0xb0100000 0x680000

Wait till it erases a part of the FLASH, then write the new content in.
This lasts around 5-6minuts, be patient and when it finishes - reboot your AZBox.
If it went well, on your TV screen you will see a standard update you came to know so well...
Plug a USB stick with Official FW and proceed as usual.

I did it all like this, connecting AZbox with PC via rs 232 and LAN connection.

Home-made but works:

whether the pin RS232 azbox can directly connect to pc using RS232 cable and conector?


Azbox HD pre+ no display menu

Hello all
new to this forums ,just got my AZbox HD premium+ and all it does is
booting,checking,loading,so tried file 5400 with USB but what happens
is I get no picture image with menu displays on TV to go to settings.
So how do I set up this box without access to display menu,Im not getting witch way to follow to get box working again,please help.

dear sir
i am having booting problem in my azbox premium hd box
i have tried with recover azbox putty tool after login page user as root
and password as azbox
its gives invaild user and password
pl help me sir


Well Known Member
What did you have in the box/what were you trying to put in to the box/what were you trying to flash it with?!?

Depending on which kernel is in there there are various ways to proceeding.

Just read the docs carefully and get appropriate files, then follow it!

Start AZUp 2.2.6 and paste the first findings of the app...

Download the files mentioned in the document above!

Good luck!
Last edited:


AZbox HD Pre +

Box is new,i put no files in ,all I did was connected to power , RCA or HDMI to TV and Ethernet connection.Then it powers on cycling on booting,checking and loading then black screen.So I get nothing showing on TV screen.I Tried AZloader 1.45/ Com1/ open for file/ but on files of type it says image file /.img and file for AZBox is patch.bin. Am I wrong? to use v 2.2.6 I dont know IP of AZBox.
Last edited:


Well Known Member
AZbug must be connected to your router. Enter your router's interface from your PC (Firefox would do) and see AZbox HD IP (192.168.x.x).

Then, fire up AZUp 2.2.6 and put in the address correctly, then choose the FW, if you want to put in the latest Enigma2 based on OpenPLi.

Depending on what AZUp tells you, if you have an old kernel in (original), then you can use original FW of your choosing...

You have my "How to"s for both OFW and E2... Detailed!

If not, send it to OpenSat to sort it out!


Azbox HD pre+ no display menu

I have azbox set up with connected to modem router via ethernet,
and usb connection to computer,I have gateway configuration open and going under DHCP I see IP address and mac #,i then opened AZup
v2.2.6 and I hit install official FW and it says connecting but after few seconds error message Could not open connection to the host - IP address.
A'm I missing something Thanks in advance.


Well Known Member
How is your PC connected to the router? It should be LAN or WLAN.

What is the IP address of the AZ?

And PC?

Both in the 192.168.x.x range?

Let's start there...