Oscam Emu Chat Thread

  • Thread starter ooOO_SORGOS_OOoo
  • Start date

ro_54

Active member
Messages
529
Thanks, what view are you talking about?
Is the oscam livelog? Is there any way to calculate it simply based on the namespace? I mean something like the CRC32 or Adler32?
Many thanks.
in oscam.conf, you need to add this line in order to see the hash # in the status screen:"initial_debuglevel = 2"
I do not know about the namespace. maybe more experienced members can help you with this.
 

sentaro2

Member
Messages
31
As far as i can understand:
if I have an Enigma namespace (including freq) that is 0x00462B22 (on Service ID 1), I have to:
1) remove the more significant 4 bits from the Enigma namespace and change it with the Oscam identifier (0xA):
==> 0xA0462B22
2) add the SID before the E2 namespace:
==> 0001A0462B22

Then I have to calc the CRC32 on it, but I am lost at this stage:
hash = crc32(caid, ecm_copy + ecm_len - 6, 6)

Are we saying we need the ECM to generate the namespace hash from the namespace?


thx
 

sheypooor

Member
Messages
68
Hi every one
My oscam dont open afn channel but a month ago every thing ok
Pleas help me
 

3satbox

Active member
Messages
212
Hi every one
Install ncam
 

ro_54

Active member
Messages
529
Install ncam
...or oscam 11714 build by mohamed.
 

123ghj789

Registered
Messages
4
...or oscam 11714 build by mohamed.
Tried it (cygwin version); german channels do not open though, even though I can see the dcws coming regularly. Other crypt systems work fine. Are there peculair settings to put in config files to make it work for german bouquet?
 

123ghj789

Registered
Messages
4
The same happens with Ncam 13.2 btw...
 

malvin1

New member
Messages
2
OSCam + CI+ mediacard problem.
Box with DVB-S, DVB-T and DVB-C tuners.
The DVB-C channels descrambled with CI+ mediacard.

The ECM-s on the DVB-C channels are as follows:
ECMPid 01F2 (498) 0B00-Conax
ECMPid 01F3 (499) 1801-Nagra
ECMPid 01F0 (496) 1854-Nagra
ECMPid 01F1 (497) 1868-Nagra

My problem is, that the OSCam also "challenges" ECM 0B00, and fails of course:
(dvbapi) Demuxer 0 trying to descramble PID 2 CAID 0B00 PROVID 000000 ECMPID 01F2 ANY CHID PMTPID 0190 VPID 0191
(ecm) dvbapiau (P: 0B00:000000:0518:01F2:0000 #ECM_L:6D #CW=00000000000000000000000000000000 HOP:01): rejected (1 ms) by Venton - ATV HD
(ecm) dvbapiau (P: 0B00:000000:0518:01F2:0000 #ECM_L:6D #CW=00000000000000000000000000000000 HOP:01): rejected (1 ms) by Venton - ATV HD
(dvbapi) Demuxer 0 restarting decoding requests after 5 ms with 1 enabled and 3 disabled ecmpids!

If I ignore the service in oscam.dvbapi (I: 0B00:000000:0518:01F2 or I: ::0518), the result is the following:
2022/10/18 05:55:15 6638B0ED c (dvbapi) Demuxer 0 no enabled matching ecmpids -> decoding is waiting for matching readers!
2022/10/18 05:55:19 6638B0ED c (dvbapi) Demuxer 0 no enabled matching ecmpids -> decoding is waiting for matching readers!
that means, it is trying every 4 secs anyway.

This is a bit more rare, than without ignoration, but (as the box is quite old), it is still an unnecessary extra load,
which causes problems in "more complex situations" (PiP, several recordings - when the OSCam has a "real" task as well)

E.g.
The swap PiP changes, but one of the picture is black;
One or both scheduled recording is "blackness";

At channels not with mediacard (that is DVB-S + DVB-T) all these "cases" work perfectly.

How could I fully disable these 0B00 ECM-s in OSCam ?
 

rpl

New member
Messages
16
decoding is waiting for matching readers!
Your assumption is incorect
that means, it is trying every 4 secs anyway.
That doesn’t means that CAID is tried every 4 seconds. It means something entirely different. Oscam is checking if there is any reader with matching CAID, you can activate reader during channel watching or dose the pmt hase changed. It will always do that. In this case when you ignored specific one specific CAID and don't have readers for other you will get that messege. Even when you ignore all CAID you also will have that messege. Oscam constantly looking for matching reader or pmt change, dosen’t mean it Is trying to decode if there is no reader to do that.

Try commoninterface channel assignments instead.
 

[email protected]

(∩`-´ )⊃━☆゚.*・。゚
Staff member
Super Moderator
Messages
23,410
new.gif

Changeset 11715

-Added new ATR
-Refresh some Prov. Info

Thanks bust3d
 

saturn9

New member
Messages
26
Hi - s*kde using Oscam R11715-798 icam mod results in the following log message:

(ecm) icam (P: 098D:000000:0083:0000:025B: #ECM_L:A7 #CW=00000000000000000000000000000000 HOP:00): rejected group (0 ms) - **************** HD (no matching reader)

I thought the modded CAM would decode or do I need ICAM server access as well? Am I misunderstanding something?
 

SAT_Nobody

Member
Messages
171
of course you need ICAM server as well
 

cpr43

Member
Messages
232
Hello. Is there any Oscam version doing autoroll using EMM for AFN on Dreambox? I have older version who find ECMs but dark screen. Thanks for help
 

3satbox

Active member
Messages
212
Any of the latest will do the job. Even 11711 does it...
 

cpr43

Member
Messages
232
I
Any of the latest will do the job. Even 11711 does it...
I have 11738 and it does autoroll , find keys but screen is dark
 

3satbox

Active member
Messages
212
1st q - do you use oscam-emu or just oscam
2nd - check your settings & emmkez again
 

EnoSat

Well-known member
Messages
1,407
I have 11738 and it does autoroll , find keys but screen is dark
check extended_cw_api and disablecrccws
 

cpr43

Member
Messages
232
Sorry should I said 11538. Emm is finding ECMs but screen is dark.
 

cpr43

Member
Messages
232
check extended_cw_api and disablecrccws
Ok will try and feed back. Thanks
 

cpr43

Member
Messages
232
check extended_cw_api and disablecrccws
I have options. Actually set for my OE which is OE2.0. Should I change to 0 and restart gui? Thanks
0- none (disabled)
1- OE2.2
2- OE2.0
 
Top