Oscam Emu and Biss channels

TheJackal

Registered
Messages
5
Hi all ,

I have a vps and i installed oscam emu and i have been looking for a way to run biss channels to cccam clients and i tried every possible solution ,but still no luck

When i select any biss channel on the stb i can't see any info in the user or from emu in the live log

is such thing even possible ? if so what Am i missing ? can you please provide me with detailed info for the config and reader ?

Regards
 

TheJackal

Registered
Messages
5
Easy add softcam and make reader and set group number
i did that already , but still no luck

Here is the reader :
[reader]
label = emulator
protocol = emu
device = emulator
disablecrccws_only_for = 0E00:000000
caid = 0500,0604,0E00,1010,1801,2600,2602,2610
detect = cd
ident = 0500:000000,007400,007800,021110,023800;0604:000000;0E00:000000;1010:000000;1801:000000,001101,002111,007301;2600:000000;2602:000000;2610:000000
group = 1
emmcache = 2,1,2,1
emu_auproviders = 0604:010200;0E00:000000;1010:000000;2610:000000

and the user:
[account]
user = user1
pwd = pass1
au = 1
group = 1,2
max_connections = 2

No info is sent from cccam client when selecting any biss channel , like it is fta channel !

regards
 

TheJackal

Registered
Messages
5
reader can be made better
please can you provide me with a better reader to try ?

another thing , are sure that cccam client send biss channel info to oscam emu ?

tried PowerVu and all ok , but for biss nothing worked

regards
 
  • Like
Reactions: ms8

EnoSat

Well Known Member
Messages
1,919
Here is the reader
label = emulator
protocol = emu
device = emulator
disablecrccws_only_for = 0E00:000000
caid = 0500,0604,0E00,1010,1801,2600,2602,2610
detect = cd
ident = 0500:000000,007400,007800,021110,023800;0604:000000;0E00:000000;1010:000000;1801:000000,001101,002111,007301;2600:000000;2602:000000;2610:000000
group = 1
emmcache = 2,1,2,1
emu_auproviders = 0604:010200;0E00:000000;1010:000000;2610:000000
red - dead or unused caid/providers
 

EnoSat

Well Known Member
Messages
1,919
it is useless to create another CCW reader if oscam already has an EMU reader
 

ckkckk

Registered
Messages
23
Hi all ,

I have a vps and i installed oscam emu and i have been looking for a way to run biss channels to cccam clients and i tried every possible solution ,but still no luck

When i select any biss channel on the stb i can't see any info in the user or from emu in the live log

is such thing even possible ? if so what Am i missing ? can you please provide me with detailed info for the config and reader ?

Regards
I am also having a problem with this issue. No matter what I did, I didn't succeed. I also tried with cs357x but it didn't work.
 

EnoSat

Well Known Member
Messages
1,919
Did you turn on debugging in LiveLog?
Have you enabled EMU for clients?
Have you enabled the reader user?
 

ckkckk

Registered
Messages
23
OSCam: 1.20_svn Build: r11718-798 Compiler: i686-pc-cygwin-ssl-libusb

oscam.conf
Code:
[global]
logfile                       = stdout

[cache]

[cccam]
port                          = 6666
nodeid                        = B0D71597105F14D6
version                       = 2.0.11

[streamrelay]

[webif]
httpport                      = 8888
httpallowed                   = 127.0.0.1,192.168.0.0-192.168.255.255,10.0.0.0-10.255.255.255,172.16.0.0-172.31.255.255,255.255.255.255


oscam.user
Code:
[account]
user                          = test_cccam
pwd                           = 123456
group                         = 1

oscam.server
Code:
[reader]
label                         = emulator
protocol                      = emu
device                        = emulator
caid                          = 2600,2602,2610
detect                        = cd
ident                         = 2600:000000;2602:000000;2610:000000
group                         = 1
emmcache                      = 2,1,2,1
emu_auproviders               = 0604:010200;0E00:000000;1010:000000;2610:000000

SoftCam.Key
Code:
F 2986065E 00000000 198519B787199636 ;TEST (42.0°E)

log
Code:
20:20:06 00000000 s >> OSCam << cardserver log switched, version 1.20_svn, build r11718-798 (i686-pc-cygwin-ssl-libusb)
20:20:06 00000000 s     (main) System name    = CYGWIN_NT-10.0-WOW
20:20:06 00000000 s     (main) Host name      = CKK-10
20:20:06 00000000 s     (main) Release        = 2.11.2(0.329/5/3)
20:20:06 00000000 s     (main) Version        = 2018-11-08 14:30
20:20:06 00000000 s     (main) Machine        = i686
20:20:06 00000000 s     (main) creating pidfile /cygdrive/c/Users/ckk/AppData/Local/Temp/_oscam/oscam.pid with pid 4668
20:20:06 00000000 s      (emu) OSCam-Emu version 798
20:20:06 00000000 s   (config) userdb reloaded: 1 accounts loaded, 0 expired, 0 disabled
20:20:06 00000000 s     (main) signal handling initialized
20:20:06 00000000 s      (net) cccam: initialized (fd=3, port=6666)
20:20:06 00000000 s   (reader) emulator [emu] creating thread for device emulator
20:20:06 5851F42D h    (webif) webif: decompressed 179851 bytes back into 443372 bytes
20:20:06 5851F42D h    (webif) HTTP Server running. ip=0.0.0.0 port=8888
20:20:06 00000000 s     (main) waiting for local card init
20:20:06 1630BBA4 r      (emu) Stream key delayer initialized
20:20:06 00000000        (emu) INFO: FFDecsa parallel mode = 32
20:20:06 1630BBA4 r      (emu) Stream relay server initialized
20:20:06 1630BBA4 r   (reader) emulator [emu] Reader initialized (device=emulator, detect=cd, mhz=357, cardmhz=357)
20:20:07 1630BBA4 r   (reader) emulator [emu] card detected
20:20:08 1630BBA4 r   (reader) emulator [emu] found card system emu
20:20:08 1630BBA4 r   (reader) emulator [emu] THIS WAS A SUCCESSFUL START ATTEMPT No  1 out of max allotted of 1
20:20:08 1630BBA4 r      (emu) Reading key file: ./SoftCam.Key
20:20:08 1630BBA4 r      (emu) Total keys in memory: W:0 V:0 N:0 I:0 F:1 G:0 P:0 T:0 A:0
20:20:09 00000000 s     (main) init for all local cards done
20:20:09 00000000 s (emmcache) loading emmcache disabled since no reader is using it!
20:20:09 00000000 s (emmcache) loading emmstats disabled since no reader is using it!
20:20:09 00000000 s (anticasc) anti cascading disabled
20:20:09 00000000 s     (gbox) local gbox failed init
20:20:09 7BCDABCB c   (client) encrypted cccam-client 127.0.0.1 granted (test_cccam, au=off)


Alt-DVB, Hadu

luu5i2n.jpg

4xq2gny.jpg
 

ckkckk

Registered
Messages
23
There is no problem with dvbapi.

oscam.conf
Code:
[global]
logfile                       = stdout

[cache]

[cccam]
port                          = 6666
nodeid                        = B0D71597105F14D6
version                       = 2.0.11

[streamrelay]

[dvbapi]
enabled                       = 1
au                            = 1
pmt_mode                      = 0
listen_port                   = 633
delayer                       = 60
user                          = test_cccam
read_sdt                      = 1
write_sdt_prov                = 1
extended_cw_api               = 1
boxtype                       = pc

[webif]
httpport                      = 8888
httpallowed                   = 127.0.0.1,192.168.0.0-192.168.255.255,10.0.0.0-10.255.255.255,172.16.0.0-172.31.255.255,255.255.255.255


log
Code:
21:30:17 00000000 s >> OSCam << cardserver log switched, version 1.20_svn, build r11718-798 (i686-pc-cygwin-ssl-libusb)
21:30:17 00000000 s     (main) System name    = CYGWIN_NT-10.0-WOW
21:30:17 00000000 s     (main) Host name      = CKK-10
21:30:17 00000000 s     (main) Release        = 2.11.2(0.329/5/3)
21:30:17 00000000 s     (main) Version        = 2018-11-08 14:30
21:30:17 00000000 s     (main) Machine        = i686
21:30:17 00000000 s     (main) creating pidfile /cygdrive/c/Users/ckk/AppData/Local/Temp/_oscam/oscam.pid with pid 8012
21:30:17 00000000 s      (emu) OSCam-Emu version 798
21:30:17 00000000 s   (config) userdb reloaded: 1 accounts loaded, 0 expired, 0 disabled
21:30:17 00000000 s     (main) signal handling initialized
21:30:17 00000000 s   (config) 1 provid's loaded
21:30:17 00000000 s   (config) 1 service-id's loaded in 0 ms
21:30:17 00000000 s      (net) cccam: initialized (fd=3, port=6666)
21:30:17 00000000 s   (reader) emulator [emu] creating thread for device emulator
21:30:17 5851F42D h    (webif) webif: decompressed 179851 bytes back into 443372 bytes
21:30:17 5851F42D h    (webif) HTTP Server running. ip=0.0.0.0 port=8888
21:30:17 00000000 s     (main) waiting for local card init
21:30:17 7371700A r      (emu) Stream key delayer initialized
21:30:17 00000000        (emu) INFO: FFDecsa parallel mode = 32
21:30:17 7371700A r      (emu) Stream relay server initialized
21:30:17 7371700A r   (reader) emulator [emu] Reader initialized (device=emulator, detect=cd, mhz=357, cardmhz=357)
21:30:18 7371700A r   (reader) emulator [emu] card detected
21:30:19 7371700A r   (reader) emulator [emu] found card system emu
21:30:19 7371700A r   (reader) emulator [emu] THIS WAS A SUCCESSFUL START ATTEMPT No  1 out of max allotted of 1
21:30:19 7371700A r      (emu) Reading key file: ./SoftCam.Key
21:30:19 7371700A r      (emu) Total keys in memory: W:0 V:0 N:0 I:0 F:1 G:0 P:0 T:0 A:0
21:30:19 00000000 s     (main) init for all local cards done
21:30:19 00000000 s (emmcache) loading emmcache disabled since no reader is using it!
21:30:19 00000000 s (emmcache) loading emmstats disabled since no reader is using it!
21:30:19 00000000 s (anticasc) anti cascading disabled
21:30:19 00000000 s     (gbox) local gbox failed init
21:30:19 04962306 c   (client) plain dvbapi-client granted (test_cccam, au=off)
21:30:19 04962306 c   (dvbapi) dvbapi channelcache loaded from ./oscam.ccache
21:30:19 04962306 c   (dvbapi) Using TCP listen socket, API forced to DVBAPIv3 (0), userconfig boxtype: 11
21:30:23 04962306 c   (dvbapi) Client connected: 'dvbapiNET v1.0 (#1e92563b)' (protocol version = 2)
21:30:26 04962306 c   (dvbapi) Demuxer 0 ecmpid 0 CAID: 2600 ECM_PID: 1FFF PROVID: 000000
21:30:26 04962306 c   (dvbapi) Demuxer 0 found 1 ECM pids and 2 STREAM pids in CA PMT
21:30:26 04962306 c   (dvbapi) Demuxer 0 trying to descramble PID 0 CAID 2600 PROVID 000000 ECMPID 1FFF ANY CHID PMTPID 0026 VPID 065E
21:30:26 7371700A r      (emu) Key not found: F EA48F7A2
21:30:26 7371700A r      (emu) Key not found: F 298606C2
21:30:26 7371700A r      (emu) Key found: F 2986065E 00000000
21:30:26 04962306 c      (ecm) test_cccam (2600@000000/0000/2986/13:59E485CF747445EDAEA813B3DFEE94DE): found (4 ms) by emulator - TEST
21:30:27 04962306 c   (dvbapi) Demuxer 0 stopped descrambling for program 2986 (TEST)
21:30:27 04962306 c   (dvbapi) Demuxer 0 ecmpid 0 CAID: 2600 ECM_PID: 1FFF PROVID: 000000
21:30:27 04962306 c   (dvbapi) Demuxer 0 found 1 ECM pids and 2 STREAM pids in CA PMT
21:30:27 04962306 c   (dvbapi) Demuxer 0 found channel in cache and matching prio -> start descrambling ecmpid 0
21:30:27 04962306 c   (dvbapi) Demuxer 0 trying to descramble PID 0 CAID 2600 PROVID 000000 ECMPID 1FFF ANY CHID PMTPID 0026 VPID 065E
21:30:27 7371700A r      (emu) Key not found: F EA48F7A2
21:30:27 7371700A r      (emu) Key not found: F A861042E
21:30:27 7371700A r      (emu) Key not found: F 298606C2
21:30:27 7371700A r      (emu) Key found: F 2986065E 00000000
21:30:27 04962306 c      (ecm) test_cccam (2600@000000/0000/2986/13:454E52F95125D44EECC2B1A983267694): found (4 ms) by emulator - TEST
 

ckkckk

Registered
Messages
23
I did not activate this option, but either way there is no changes.

Same in DVBJCAM or any other app or even other device.
 
Last edited:

EnoSat

Well Known Member
Messages
1,919
After all, he already described the whole thing,
server oscam with emu in box,
various clients on the cccam protocol (e.g. hadu)
 

ckkckk

Registered
Messages
23
I did not activate this option, but either way there is no changes.

Same in DVBJCAM or any other app or even other device.
There is nothing left to try. I think there is a restriction on biss via cccam in Oscam. Maybe it should be tried on another platform, but I can only try it on Windows.
 
Top