Help with Plugins

satellitestuff

Registered
Messages
52
Hi all, I've recently took the plunge into finally updating my receiver to Openvix 6.2.011, but it doing so I've lost the ability to pick up BISS feeds by wiping the plugins.

Is anyone able to talk me through setting everything up, as it's been years since I last used it, and I've totally forgotten the process. From about 3 years ago, I vaguely remember having to do Telnet stuff, and changing things in Openwebif, but I'm in fear of bricking the box if I mess about too much!

I vaguely remember having a plugin called 'Alternative Softcam Mnager' (or something similar) which worked great when set up as I could easily add the BISS info into a constant.cw file and the FTPing it to the box. I also used something called AddKey. which let you type in the key from an on-screen keyboard.

I briefly tried installing couple of Oscam plugins last night, but it said the configuration needed to be set up, which I've no idea how to do, resulting in a long error message with red text on the screen - crashing the box.

I've now reflashed everything back to the latest firmware today, and can hopefully start from scratch with your help! The simplest way would be great. Thanks!
 

kegnkiwi

Super VIP
Donating Member
Messages
926
If you cannot find anything in the plugins menu to download reference keys etc, then maybe an alternative panel would be suitable. Something like the satvenus panel or levi45 panel which are supplied as an ipk file might be suitable. You would need to be able to send the ipk file to your box and then install the plugin manually via the remote. From there you can download all the softcams you want.
 

Ferret

Marching On Together !
Staff member
Administrator
Messages
17,550
Hi all, I've recently took the plunge into finally updating my receiver to Openvix 6.2.011, but it doing so I've lost the ability to pick up BISS feeds by wiping the plugins.

Is anyone able to talk me through setting everything up, as it's been years since I last used it, and I've totally forgotten the process. From about 3 years ago, I vaguely remember having to do Telnet stuff, and changing things in Openwebif, but I'm in fear of bricking the box if I mess about too much!

I vaguely remember having a plugin called 'Alternative Softcam Mnager' (or something similar) which worked great when set up as I could easily add the BISS info into a constant.cw file and the FTPing it to the box. I also used something called AddKey. which let you type in the key from an on-screen keyboard.

I briefly tried installing couple of Oscam plugins last night, but it said the configuration needed to be set up, which I've no idea how to do, resulting in a long error message with red text on the screen - crashing the box.

I've now reflashed everything back to the latest firmware today, and can hopefully start from scratch with your help! The simplest way would be great. Thanks!
Do you have any oscam configs backed up ?

Start with a softcam Oscam if you like you can do that on the plugin menu.

Menu-setup-plugin

Then you need to FTP your saved configs into etc/tuxbo/config/oscam

Then start oscam and it wont report config issuse
 

satellitestuff

Registered
Messages
52
Do you have any oscam configs backed up ?

Start with a softcam Oscam if you like you can do that on the plugin menu.

Menu-setup-plugin

Then you need to FTP your saved configs into etc/tuxbo/config/oscam

Then start oscam and it wont report config issuse

Sadly not. I thought I'd backed everything up to a USB stick few months ago (I even remember it being in some sort of Linix file system) - but nothing seemed to be there when I checked. What would a working config file look like? Is it possible to get a dummy one from somewhere that would work?

If you cannot find anything in the plugins menu to download reference keys etc, then maybe an alternative panel would be suitable. Something like the satvenus panel or levi45 panel which are supplied as an ipk file might be suitable. You would need to be able to send the ipk file to your box and then install the plugin manually via the remote. From there you can download all the softcams you want.

I found an IPK for satvenus, and copied it to /tmp but got the following message when trying to install:
"Cannot satisfy the following dependencies for enigma2-plugin-extensions-satvenus-panel_7.3.2_all - python-html"
 

Ferret

Marching On Together !
Staff member
Administrator
Messages
17,550
Sadly not. I thought I'd backed everything up to a USB stick few months ago (I even remember it being in some sort of Linix file system) - but nothing seemed to be there when I checked. What would a working config file look like? Is it possible to get a dummy one from somewhere that would work?



I found an IPK for satvenus, and copied it to /tmp but got the following message when trying to install:
"Cannot satisfy the following dependencies for enigma2-plugin-extensions-satvenus-panel_7.3.2_all - python-html"
Install satvenus from the tmp folder with these telnet commands

opkg update
hit enter
opkg install /tmp/*.ipk
hit enter

attached are oscam configs
 

Attachments

  • oscam.rar
    734 bytes · Views: 31

EnoSat

Well Known Member
Messages
2,011
Is anyone able to talk me through setting everything up, as it's been years since I last used it, and I've totally forgotten the process. From about 3 years ago, I vaguely remember having to do Telnet stuff, and changing things in Openwebif, but I'm in fear of bricking the box if I mess about too much!
copy binary files in /usr/softcams/
image automated create script for this binary in /etc/init.d/
 

satellitestuff

Registered
Messages
52
Still no joy, unfortunately... :(
Going back to the instructions on post #3, I started from scratch and downloaded and installed 'oscam-latest' from the receivers plugins menu, and copied Ferret's config files into etc/tuxbo/config/oscam. That stopped all of the error messages, but I'm still struggling to get BISS working. I've edited and FTP'ed my constant.cw to add some active feeds today, but nothing seems to be opening up. I'm just wondering if I've not put it in the correct folder, maybe?

Also, when trying to use KeyAdder (which I've also installed), it's writing to a softcam.key - but that's also doing nothing. Could it be that oscam is not finding either my constant.cw or softcam.key files?

If all of the above seems correct to you guys, I might re-flash the box (again), in the hope that someone could generously give me a step-by-step idiots guide on how to get it back up and running! :p
 

satellitestuff

Registered
Messages
52
Could it be that oscam is not finding either my constant.cw or softcam.key files

Sorry to bump the thread, but I've worked out the issue and thought it may be of some use if anyone else has similar issues.
I noticed that the 'oscam.server' file that was uploaded by Ferret was blank, and after doing a bit of digging around, I found that I needed to add the following, and now BISS is working fine! :D

[reader]
label = biss
protocol = constcw
device = /usr/keys/constant.cw
caid = 2600
group = 1

Are there any other 'reader' commands that I would need to add to get the likes of PowerVU or SoftCam.Key files to work with Oscam?
 

EnoSat

Well Known Member
Messages
2,011
it is probably better to use a reader with an emulator protocol,
softcam.key files are updated here more often than constant.cw files
 

satellitestuff

Registered
Messages
52
it is probably better to use a reader with an emulator protocol,
softcam.key files are updated here more often than constant.cw files
Thanks EnoSat. I'm not too sure how to make one of those types of readers, but after just doing a quick Google, I found this example:

[reader]
label = emulator
protocol = emu
device = emulator
disablecrccws_only_for = 0E00:000000
caid = 0500,0604,090F,0E00,1010,1801,2600,2602,2610,4AE1
detect = cd
ident = 0500:000000,023800,021110,007400,007800;0604:000000;090F:000000;0E00:000000;1010:000000;1801:000000,007301,001101,002111;2600:000000;2602:000000;2610:000000;4AE1:000011,000014,0000FE
group = 1
emmcache = 2,1,2,1
emu_auproviders = 0604:010200;0E00:000000;1010:000000;2610:000000;4AE1:000011,000014,0000FE

Would that work for me if I addded it to my oscam.server file? Or do I need to amend it, or use a different command entirely? I've seen another version of the above, but with device = /etc/tuxbox/config/SoftCam.Key used instead.
 

EnoSat

Well Known Member
Messages
2,011
it depends on the compilation of oscam, in LiveLog you will see whether it is expecting a file in predefined directories or is waiting for a device definition
-oscam.server-
Code:
[reader]
label = EMU
protocol = emu
device = emulator
disablecrccws_only_for = 0E00:000000
caid = 0500,0E00,1010,2600
detect = cd
ident = 0500:021110;0E00:000000;1010:000000;2600:000000
group = 1
emmcache = 2,1,2,1
emu_auproviders = 0E00:000000;1010:000000
-LiveLog-
Code:
r      (emu) Stream key delayer initialized
       (emu) INFO: FFDecsa parallel mode = 32
   >> OSCam << cardserver log switched, version 1.20_svn, build r11518-796 (csky-linux-gxapi-ssl)
r      (emu) Stream relay server initialized
r   (reader) EMU [emu] Reader initialized (device=emulator, detect=cd, mhz=357, cardmhz=357)
r   (reader) EMU [emu] card detected
r   (reader) EMU [emu] found card system emu
r   (reader) EMU [emu] THIS WAS A SUCCESSFUL START ATTEMPT No  1 out of max allotted of 1
r      (emu) Reading key file: /home/gx/local/oscam/SoftCam.Key
r      (emu) Total keys in memory: W:0 V:6 N:0 I:8 F:262 G:0 P:203 T:142 A:0
 

Victor64

Registered
Messages
51
Good Morning,

I ask you kindly for help. On my Octagon SF 8008 with Openatv 7.2 image I installed the HDF radio plugin. Unfortunately, after a short good functioning and after a reboot I have the following message: No internet connection. Could you give me an advice what to do ? Thank you.
The second issue is related to the SDR plugin that is not working with the respectively image. It could the fact that I tested starting from a TV channel and not from the Radio menu ? Thank you again.
 
Top