Go Back   Sat Universe > Emulators & Cardservers > Chat > Oscam Chat

Note: Visitors from certain countries might see in-text advertising(underlind words in posts) or pop-under ads.
It is only shown to unregistered visitors or members that haven't made any posts. So you can easily get rid of it.

World-Of-Satellite

Oscam-emu can not start.

Oscam Chat

Reply
  #81  
Old 25-04-2019, 14:38  Translate from English to Italian  Translate from English to French  Translate from English to German  Translate from English to Spanish  Translate from English to Dutch  Translate from English to Greek  Translate from English to Portuguese  Translate from English to Russian  Translate from English to Russian
spanner123 spanner123 is offline
Senior Member
 
Join Date: Jun 2015
Posts: 34
Thanks: 12
Thanked 8 Times in 8 Posts
Country: Country Flag
Default

@juli13 @MadMax This was posted on another forum by @lincsat
I added a symlink to the existing libcrypto and patched the SoftcamManager to double the ulimit size and now all OScam's I've tried do run fine
Is this something that can be incorporated in future versions?
Reply With Quote
  #82  
Old 25-04-2019, 17:01  Translate from English to Italian  Translate from English to French  Translate from English to German  Translate from English to Spanish  Translate from English to Dutch  Translate from English to Greek  Translate from English to Portuguese  Translate from English to Russian  Translate from English to Russian
juli13's Avatar
juli13 juli13 is offline
 
Join Date: Feb 2009
Posts: 9,572
Thanks: 6,341
Thanked 50,704 Times in 8,421 Posts
Default

Quote:
Originally Posted by dog-man View Post
I did try to install libcrypto 0.98 on my ultimo 4k but it would not install.

From what I have read, my receiver needs a different type of libcrypto but it isn't compatible with the latest oscam-emu versions.
The oscam arm that you used, need libcrypto 1.0 to run, not the 0.98.
The other isues that are mention here, are discussed before at this threat.
__________________
Reply With Quote
  #83  
Old 25-04-2019, 17:02  Translate from English to Italian  Translate from English to French  Translate from English to German  Translate from English to Spanish  Translate from English to Dutch  Translate from English to Greek  Translate from English to Portuguese  Translate from English to Russian  Translate from English to Russian
dog-man's Avatar
dog-man dog-man is offline
 
Join Date: Jul 2010
Location: la la Land
Posts: 1,666
Thanks: 617
Thanked 1,771 Times in 818 Posts
Country: Country Flag
Default

Will the next version of oscam-emu use libcrypto 1.0.2? instead of 0.9.8?

I hope this is a possibility for those that take the time to compile new versions and provide us with the ability to view certain encryptions.
Reply With Quote
  #84  
Old 25-04-2019, 17:23  Translate from English to Italian  Translate from English to French  Translate from English to German  Translate from English to Spanish  Translate from English to Dutch  Translate from English to Greek  Translate from English to Portuguese  Translate from English to Russian  Translate from English to Russian
juli13's Avatar
juli13 juli13 is offline
 
Join Date: Feb 2009
Posts: 9,572
Thanks: 6,341
Thanked 50,704 Times in 8,421 Posts
Default

This is the last version of oscam with static libcryto, should work with all the mips receives.
Attached Files
File Type: zip oscam-11517-mipsel-emu.zip (1.14 MB, 59 views)
__________________
Reply With Quote
The Following 3 Users Say Thank You to juli13 For This Useful Post:
dog-man (25-04-2019), friga (25-04-2019), lik (25-04-2019)
  #85  
Old 25-04-2019, 17:30  Translate from English to Italian  Translate from English to French  Translate from English to German  Translate from English to Spanish  Translate from English to Dutch  Translate from English to Greek  Translate from English to Portuguese  Translate from English to Russian  Translate from English to Russian
dog-man's Avatar
dog-man dog-man is offline
 
Join Date: Jul 2010
Location: la la Land
Posts: 1,666
Thanks: 617
Thanked 1,771 Times in 818 Posts
Country: Country Flag
Default

Sadly, mine are both Arm. VU Ultimo 4K and Gigablue Quad 4K.
Reply With Quote
The Following 2 Users Say Thank You to dog-man For This Useful Post:
niloc (25-04-2019), ^[email protected]@in^ (25-04-2019)
  #86  
Old 25-04-2019, 20:19  Translate from English to Italian  Translate from English to French  Translate from English to German  Translate from English to Spanish  Translate from English to Dutch  Translate from English to Greek  Translate from English to Portuguese  Translate from English to Russian  Translate from English to Russian
^[email protected]@in^ ^G@w@in^ is offline
Senior Member
 
Join Date: Nov 2008
Posts: 232
Thanks: 294
Thanked 305 Times in 105 Posts
Country: Country Flag
Default

Quote:
Originally Posted by dog-man View Post
Sadly, mine are both Arm. VU Ultimo 4K and Gigablue Quad 4K.

I have 5 Arm receivers so you can image what a pain it is
Reply With Quote
  #87  
Old 25-04-2019, 20:48  Translate from English to Italian  Translate from English to French  Translate from English to German  Translate from English to Spanish  Translate from English to Dutch  Translate from English to Greek  Translate from English to Portuguese  Translate from English to Russian  Translate from English to Russian
dog-man's Avatar
dog-man dog-man is offline
 
Join Date: Jul 2010
Location: la la Land
Posts: 1,666
Thanks: 617
Thanked 1,771 Times in 818 Posts
Country: Country Flag
Default

The annoying thing is that my cheap Chinese receivers continue to get it as usual without any changes at all.
Reply With Quote
The Following User Says Thank You to dog-man For This Useful Post:
  #88  
Old 25-04-2019, 20:55  Translate from English to Italian  Translate from English to French  Translate from English to German  Translate from English to Spanish  Translate from English to Dutch  Translate from English to Greek  Translate from English to Portuguese  Translate from English to Russian  Translate from English to Russian
mister b mister b is offline
Member
 
Join Date: Jul 2015
Posts: 20
Thanks: 88
Thanked 25 Times in 11 Posts
Country: Country Flag
Default

Amiko alien sh4 is also not running oscam after version 11508.
Reply With Quote
  #89  
Old 25-04-2019, 21:03  Translate from English to Italian  Translate from English to French  Translate from English to German  Translate from English to Spanish  Translate from English to Dutch  Translate from English to Greek  Translate from English to Portuguese  Translate from English to Russian  Translate from English to Russian
Abu Baniaz Abu Baniaz is offline
Member
 
Join Date: Jan 2013
Posts: 10
Thanks: 37
Thanked 12 Times in 6 Posts
Country: Country Flag
Default

It's not so much as needs a particular version of libcrypto to run, just that it has been coded to look for a particular version. Newer versions should work.

If I remember correctly, the ssl version used in images was increased owing to a vulnerability. Pretty sure most images use 1.02 now.

You can try adding symlinks

ln -sf /usr/lib/libcrypto.so.1.0.2 /usr/lib/libcrypto.so.0.9.7
ln -sf /usr/lib/libssl.so.1.0.2 /usr/lib/libssl.so.0.9.7
ln -sf /usr/lib/libcrypto.so.1.0.2 /usr/lib/libcrypto.so.0.9.8
ln -sf /usr/lib/libssl.so.1.0.2 /usr/lib/libssl.so.0.9.8
ln -sf /usr/lib/libcrypto.so.1.0.2 /usr/lib/libcrypto.so.1.0.0
ln -sf /usr/lib/libssl.so.1.0.2 /usr/lib/libssl.so.1.0.0


Maybe add to postinstall script?

Last edited by Abu Baniaz; 25-04-2019 at 21:18..
Reply With Quote
The Following 3 Users Say Thank You to Abu Baniaz For This Useful Post:
femi (29-04-2019), niloc (25-04-2019), ^[email protected]@in^ (25-04-2019)
  #90  
Old 29-04-2019, 22:36  Translate from English to Italian  Translate from English to French  Translate from English to German  Translate from English to Spanish  Translate from English to Dutch  Translate from English to Greek  Translate from English to Portuguese  Translate from English to Russian  Translate from English to Russian
lakipa's Avatar
lakipa lakipa is offline
Junior Member
 
Join Date: Feb 2019
Posts: 5
Thanks: 8
Thanked 0 Times in 0 Posts
Country: Country Flag
Default

version 11517 posted #84 by juli13 works on openpli7 unofficial image box

but i have 2 issues raised with 11509+ versions and this one ofcourse



sky de cs is not working the same line works ok on another box running openatv 6.1 without needing staticlibcrypto integrated

my other receiver oscam version has id compiler type mipsel-unknown-linux-gnu-ssl-libusb

this one here is mipsel-tuxbox-linux-gnu

don't know if it makes difference




and second issue

constcw protocol for biss reader config is unknown to this oscam version


(reader) BISS [unknown] Protocol Support missing. (typ=37)

Last edited by lakipa; 29-04-2019 at 22:56..
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 03:04.


Powered by vBulletin
Copyright İ2006-2019 - Sat Universe